Coding Challenge - 2:
Problem Statement: Maximum Draws
A person is getting ready to leave and needs a pair of matching socks. If there are n colors of socks in the drawer, how many socks need to be removed to be certain of having a matching pair?
Example
There are 2 colors of socks in the drawer. If they remove 2 socks, they may not match. The minimum number to insure success is 3.
Function Description
There is the maximumDraws function in the editor below.
maximumDraws has the following parameter:
int n: the number of colors of socks
Returns
int: the minimum number of socks to remove to guarantee a matching pair.
Input Format
The first line contains the number of test cases,t .
Each of the following lines contains an integer n .
Constraints
1 ≤ 𝑡 ≤ 1000
0 < 𝑛 < 10^6
Sample Input
Function Signature :
2
1
2
Sample Output
Function Signature :
2
3
Explanation
Case 1 : Only 1 color of sock is in the drawer. Any 2 will match.
Case 2 : 2 colors of socks are in the drawer. The first two removed may not match. At least 3 socks need to be removed to guarantee success.
Now try it yourself first then move to the answer below....
.
.
.
.
.
.
.
.
Hope you tried it yourself first...
.
.
.
.
.
.
.
Solution:
Function Signature :
#include <iostream>
using namespace std;
int maximumDraws(int n) {
return n + 1;
}
int main() {
int t;
cin >> t;
while (t--) {
int n;
cin >> n;
cout << maximumDraws(n) << endl;
}
return 0;
}
Quite easy , isn't it?
Remember t is for number of test cases and n is the number of color of socks
4 Reactions
1 Bookmarks